CVE-2026-42221: nginx-ui: Unauthenticated First-Run Installer Allows Remote Initial Admin Claim
Vulnerability summary
CVE-2026-42221 is a critical (CVSS 9.8) vulnerability in 0xjacky nginx-ui. EPSS estimates a 1.34% chance of exploitation in the next 30 days, higher than 71.3% of scored vulnerabilities. 1 public exploit is recorded.
Public exploit (GitHub, Date unknown)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1 · Related 1Timeline
- 04-05-2026PublishedVulnerability first disclosed.
- 05-05-2026Last modifiedVulnerability information updated.
Description
Nginx UI is a web user interface for the Nginx web server. From version 2.0.0 to before version 2.3.8, an unauthenticated network attacker can claim the initial administrator account on a fresh nginx-ui instance during the first-run setup window. The public /api/install endpoint is reachable without authentication, and the request-encryption flow only protects payload confidentiality in transit; it does not authenticate who is allowed to perform installation. A remote attacker who reaches the service before the legitimate operator can set the admin email, username, and password, causing permanent initial-instance takeover. This issue has been patched in version 2.3.8.
CVSS metrics
3 scores · 3 sources · 1 version- CVE.orgCNA8.1HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HDiffers
- OSV · GoEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HDiffers
EPSS trend
Probability
1.34%
Chance of exploitation in the next 30 days
Percentile
71%
Versus all other CVEs
30-day change
Decrease -0.26 pp
From 1.60% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundNginx Ui
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
0xjacky1 product
- nginx-ui≥ 2.0.0, < 2.3.8
Github.com/0xJacky1 product
- Nginx-UI≥ 2.0.0, < 2.3.8 | All versions (No fix recorded)
Nginxui1 product
- nginx_ui≥ 2.0.0, < 2.3.8
3 vendors · 3 products
References
4 links- github.com/0xJacky/nginx-ui/security/advisories/GHSA-h27v-ph7w-m9fpX Refsource CONFIRMWEBAdvisoryExploitMitigationVendor Advisory
- github.com/0xJacky/nginx-uiPACKAGE