7.5

CVE-2026-59885: pyasn1: Quadratic complexity in OBJECT IDENTIFIER and RELATIVE-OID processing allows denial of service

Analyzed
AliasesGHSA-8ppf-4f7h-5ppjPYSEC-2026-3456UBUNTU-CVE-2026-59885
Published 14-07-2026Last modified 14-07-2026

Vulnerability summary

CVE-2026-59885 is a high (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in pyasn1. EPSS estimates a 0.62% chance of exploitation in the next 30 days, higher than 49.5% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
0.62%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 12 · Related 9

Timeline

  1. 14-07-2026
    PublishedVulnerability first disclosed.
  2. 14-07-2026
    Last modifiedVulnerability information updated.

Description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER, CER, and DER decoders process OBJECT IDENTIFIER and RELATIVE-OID values in quadratic time relative to the number of arcs, so a small crafted payload containing an OID with many arcs consumes excessive CPU per decode() call and can deny service to applications that decode untrusted ASN.1 data. The corresponding encoders have the same quadratic behavior when an application re-encodes previously decoded attacker-supplied values. This issue is fixed in version 0.6.4.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.62%

Chance of exploitation in the next 30 days

Percentile

50%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.62% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard65 products
  • airflow-2All versions (No fix recorded)
  • airflow-3< 3.3.0-r4
  • airflow-3-iamguarded-compatAll versions (No fix recorded)
  • apache-beam-python-3.12-sdk< 2.75.0-r1
  • authentik-2026.2< 2026.2.6-r11
Wolfi25 products
  • airflow-3< 3.3.0-r4
  • airflow-3-iamguarded-compatAll versions (No fix recorded)
  • datadog-agent-7.72-core-integrationsAll versions (No fix recorded)
  • datadog-agent-7.73-core-integrations< 7.73.3-r23
  • datadog-agent-7.74-core-integrations< 7.74.1-r24
Debian1 product
  • pyasn1< 0.4.8-3+deb12u3 | < 0.6.1-1+deb13u3 | < 0.6.4-1
Pyasn11 product
PyPI1 product
  • pyasn1< 0.6.4
Ubuntu1 product
  • pyasn1All versions (No fix recorded) | < 0.4.8-1ubuntu0.3 | < 0.4.8-4ubuntu0.3 | < 0.6.3-1ubuntu0.1

6 vendors · 94 products

References

10 links