CVE-2026-59886: pyasn1: Uncontrolled resource consumption when converting decoded REAL values
Vulnerability summary
CVE-2026-59886 is a high (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in pyasn1. EPSS estimates a 0.44% chance of exploitation in the next 30 days, higher than 38.3% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 14 · Related 9Timeline
- 14-07-2026PublishedVulnerability first disclosed.
- 15-07-2026Last modifiedVulnerability information updated.
Description
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the univ.Real type converted its mantissa, base, and exponent value to a Python float using exact big-integer exponentiation. A BER, CER, or DER encoded REAL value only a few bytes long can carry a very large exponent, causing float conversion through prettyPrint(), str(), comparison, arithmetic, int(), or an explicit float() call to consume excessive CPU and memory and hang applications that decode untrusted ASN.1 data and then print, log, or compare decoded objects. This issue is fixed in version 0.6.4.
CVSS metrics
8 scores · 8 sources · 1 version- OSV · PypiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · Red hatEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
0.44%
Chance of exploitation in the next 30 days
Percentile
38%
Versus all other CVEs
30-day change
Decrease -0.18 pp
From 0.62% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-400Uncontrolled Resource ConsumptionThe product does not properly control the allocation and maintenance of a limited resource.
- CWE-770Allocation of Resources Without Limits or ThrottlingThe product allocates a reusable resource or group of resources on behalf of an actor without imposing any intended restrictions on the size or number of resources that can be allocated.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Redhat87 products
- fence-agents< 0:4.2.1-129.el8_10.29 | < 0:4.10.0-110.el9_8.6 | < 0:4.10.0-43.el9_2.25 | < 0:4.10.0-62.el9_4.29 | < 0:4.10.0-86.el9_6.21 | < 0:4.2.1-65.el8_4.32 | < 0:4.2.1-112.el8_8.21 | < 0:4.2.1-89.el8_6.26
- fence-agents-aliyun< 0:4.2.1-129.el8_10.29 | < 0:4.10.0-110.el9_8.6 | < 0:4.10.0-43.el9_2.25 | < 0:4.10.0-62.el9_4.29 | < 0:4.10.0-86.el9_6.21 | < 0:4.2.1-65.el8_4.32 | < 0:4.2.1-112.el8_8.21 | < 0:4.2.1-89.el8_6.26
- fence-agents-aliyun-debuginfo< 0:4.2.1-129.el8_10.29 | < 0:4.2.1-65.el8_4.32 | < 0:4.2.1-112.el8_8.21 | < 0:4.2.1-89.el8_6.26
- fence-agents-all< 0:4.2.1-129.el8_10.29 | < 0:4.10.0-110.el9_8.6 | < 0:4.10.0-43.el9_2.25 | < 0:4.10.0-62.el9_4.29 | < 0:4.10.0-86.el9_6.21 | < 0:4.2.1-65.el8_4.32 | < 0:4.2.1-112.el8_8.21 | < 0:4.2.1-89.el8_6.26
- fence-agents-amt-ws< 0:4.2.1-129.el8_10.29 | < 0:4.10.0-110.el9_8.6 | < 0:4.10.0-43.el9_2.25 | < 0:4.10.0-62.el9_4.29 | < 0:4.10.0-86.el9_6.21 | < 0:4.2.1-65.el8_4.32 | < 0:4.2.1-112.el8_8.21 | < 0:4.2.1-89.el8_6.26
Chainguard65 products
- airflow-2All versions (No fix recorded)
- airflow-3< 3.3.0-r4
- airflow-3-iamguarded-compatAll versions (No fix recorded)
- apache-beam-python-3.12-sdk< 2.75.0-r1
- authentik-2026.2< 2026.2.6-r11
Wolfi25 products
- airflow-3< 3.3.0-r4
- airflow-3-iamguarded-compatAll versions (No fix recorded)
- datadog-agent-7.72-core-integrationsAll versions (No fix recorded)
- datadog-agent-7.73-core-integrations< 7.73.3-r23
- datadog-agent-7.74-core-integrations< 7.74.1-r24
Debian1 product
- pyasn1< 0.4.8-3+deb12u3 | < 0.6.1-1+deb13u3 | < 0.6.4-1
Pyasn11 product
- pyasn1< 0.6.4
PyPI1 product
- pyasn1< 0.6.4
Ubuntu1 product
- pyasn1All versions (No fix recorded) | < 0.4.8-1ubuntu0.3 | < 0.4.8-4ubuntu0.3 | < 0.6.3-1ubuntu0.1
7 vendors · 181 products
References
61 links- github.com/pyasn1/pyasn1/security/advisories/GHSA-hm4w-wwcw-mr6rX Refsource CONFIRMWEBAdvisoryARTICLEREPORTThird Party Advisory
- github.com/pyasn1/pyasn1/commit/e60c691cb91addb8fcefa2f537e85ede6fb1e886X Refsource MISCWEBFIXARTICLEPatch
- github.com/pyasn1/pyasn1PACKAGE