CVE-2026-84315: Nginx UI OTP secure-session step-up is missing on sensitive mutation routes
Vulnerability summary
CVE-2026-84315 is a high (CVSS 8.3) Missing Authorization vulnerability in 0xjacky nginx-ui. EPSS estimates a 0.34% chance of exploitation in the next 30 days, higher than 27.1% of scored vulnerabilities.
Not severe (CVSS 8.3, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 12-10-2026PublishedVulnerability first disclosed.
- 13-10-2026Last modifiedVulnerability information updated.
Description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, Nginx UI does not apply RequireSecureSession to multiple authenticated mutation routes even though OTP-enabled users are expected to present a fresh X-Secure-Session-ID for sensitive actions. A stolen authenticated session can therefore create or alter automatic backups, DNS credentials and records, certificates and ACME users, Nginx control settings, and site or stream automation without completing the OTP or passkey step-up. This issue is fixed in version 2.4.1.
CVSS metrics
3 scores · 3 sources · 1 version- CVE.orgCNA8.3HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
- OSV · GoEcosystem advisory · calculated8.3HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
EPSS trend
Probability
0.34%
Chance of exploitation in the next 30 days
Percentile
27%
Versus all other CVEs
30-day change
Change unavailable
Change unavailable
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
0xjacky1 product
- nginx-ui< 2.4.1
Github.com/0xJacky1 product
- Nginx-UI< 1.9.10-0.20260703131214-23d1934099b0
2 vendors · 2 products
References
5 links- github.com/0xJacky/nginx-uiPACKAGE