CVE-2023-34240: Weak passwords allowed in cloudexplorer-lite
Vulnerability summary
CVE-2023-34240 is a critical (CVSS 9.8) Weak Password Requirements vulnerability in cloudexplorer-dev cloudexplorer-lite. EPSS estimates a 0.46% chance of exploitation in the next 30 days, higher than 40.1% of scored vulnerabilities.
Not severe (CVSS 6.5, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 27-06-2023PublishedVulnerability first disclosed.
- 27-11-2024Last modifiedVulnerability information updated.
Description
Cloudexplorer-lite is an open source cloud software stack. Weak passwords can be easily guessed and are an easy target for brute force attacks. This can lead to an authentication system failure and compromise system security. Versions of cloudexplorer-lite prior to 1.2.0 did not enforce strong passwords. This vulnerability has been fixed in version 1.2.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS metrics
2 scores · 2 sources · 1 version- CVE.orgCNA6.5MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NDiffers
EPSS trend
Probability
0.46%
Chance of exploitation in the next 30 days
Percentile
40%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.46% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Cloudexplorer-dev1 product
- cloudexplorer-lite< 1.2.0
Fit2cloud1 product
- cloudexplorer_lite< 1.2.0
2 vendors · 2 products
References
1 links- github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-px4m-5j22-5mw4X Refsource CONFIRMVendor Advisory